Napraw błąd: Wygląda na to, że w Twojej instalacji PHP brakuje rozszerzenia MySQL wymaganego przez WordPress

"Wygląda na to, że w Twojej instalacji PHP brakuje rozszerzenia MySQL wymaganego przez WordPress„Jest błędem napotykanym przez wielu właścicieli blogów i witryn WordPress.
To nie jest powód do niepokoju. Brak rozszerzenia MySQL z PHP jest typowy dla systemów operacyjnych instalowanych od podstaw, VPS lub serwerów dedykowanych, w których rozszerzenia PHP nie były częścią pakietu instalacyjnego. Ten problem występuje w obu przypadkach Ubuntu oraz CentOS, W tym scenariuszu problem został rozwiązany bardzo prosto dzięki aktualizacji PHP i instalacji modułu ”php-mysql".
Zaktualizuj PHP i zainstaluj rozszerzenie MySQL na Ubuntu

apt-get update
apt-get install php-mysql

Zaktualizuj PHP i zainstaluj rozszerzenie MySQL na CentOS

yum update
yum install php70w-mysql

Po tym kroku uruchom ponownie usługę Apache lub nginx.

Zetknąłem się również ze scenariuszem, w którym chociaż rozszerzenie MySQL istnieje w PHP, blog utworzony na WordPress wyświetlał błąd „Wygląda na to, że w instalacji PHP brakuje rozszerzenia MySQL wymaganego przez WordPress”. Przez większość czasu błąd występuje podczas instalowania WordPress. Tym razem jednak pojawił się na blogu, który był aktywny od kilku lat.
W tej sytuacji odkryłem, że problemem nie są moduły PHP, ale bardzo stara wersja WordPress, która nie jest już kompatybilna z PHP 7.4.4RC1. Prosta aktualizacja WordPress do najnowszej wersji rozwiązała błąd.

Napraw błąd: Wygląda na to, że w Twojej instalacji PHP brakuje rozszerzenia MySQL wymaganego przez WordPress

O autorze

podstęp

Pasjonat wszystkiego, co oznacza gadżet i informatykę, z przyjemnością piszę na stealthsettings.com od 2006 i uwielbiam odkrywać nowe rzeczy na temat komputerów i macOS, systemów operacyjnych Linux, Windows, iOS i Android.

Zostaw komentarz