Naprawiono problem: Serwer działa w wersji PHP 5.1.6 Ale 3.2.1 wymaga przynajmniej 5.2.4 WordPress.

Wskazówka dla wszystkich, nie jest dobrze znany, że dla zainstalować lub dokonać uaktualnienieJest nowsza wersja 3.2Konieczne jest, aby być zainstalowana nowsza wersja 5.2.4.

Jeśli serwer jest zainstalowanie wersji PHP starszych niż 5.2.4 zainstalować wersję WordPress 3.2.1Pojawi się błąd / Wiadomość "Serwer działa w wersji PHP 5.1.6 Wymaga WordPress 3.2.1 ale przynajmniej 5.2.4".
Problem można rozwiązać w bardzo prosty sposób przez uaktualnienie PHP, ale przed jej kilka rzeczy, należy rozważyć. Pierwszy, upgrade PHP jest możliwe na dzielonego hostingu. Więc można zrobić upgrade, musisz mieć uprawnienia administratora na serwerze (Dedicated Server lub VPS). W drugim, przed uaktualnieniem do udokumentowania i należy pamiętać, że Nowa wersja PHP nie podano Błędy innych witryn na tym serwerze.

Dla jest najczęściej stosowany system operacyjny dla Serwery WWW (Agreart i / WHMA) pokazuje, jak to zrobić upgrade do PHP na CentOS 5.2.10.x 5 32-bitowym.

Upgrade PHP na CentOS 5.1.x 5.2.x do 5.x 32-bitowym

1. Sprawdź, które pakiety są instalowane / moduły PHP (np. php-mcrypt) wraz ze standardowym pakiecie. Jeśli istnieją, powinny być usunięte lub actuzlizate.

Sprawdzanie zainstalowanych pakietów:

rpm-qa | grep php

old_php_version

2. Dodaj repozytoria dla Konieczny uaktualnienie'S wersja PHP.

nano / etc / yum.repos.d / CentOS-Testing.repo

Nowy plik (CentOS-Testing.repo) Czy dodać następujący kod (copy / paste):

[C5-testing]
name = CentOS-Testing 5
baseurl = http://dev.centos.org/centos/ $ releasever / testing / $ basearch /
enabled = 1
gpgcheck = 1
gpgkey = http://dev.centos.org/centos/RPM-GPG-KEY-CentOS-testing
includepkgs = php *

Ctrl + X aby zapisać plik CentOS-Testing.repo.

3. Aktualizacja PHP przez yum:

yum update

4. restart / httpd :

httpd restart usługi

Po restarcie httpd i sprawdzić wersję zainstalowanych pakietów:

new_php_version

Sprawdź za błędy w modułach / pakietów:

php-v

PHP Upgrade / CentOS 32-bit (i386).

Naprawiono problem: Serwer działa w wersji PHP 5.1.6 Ale 3.2.1 wymaga przynajmniej 5.2.4 WordPress.

O autorze

Stealth LP

Założyciel i redaktor Ustawienia StealthW dniu 2006.
Doświadczenie w systemach Linux operacyjnych (szczególnie CentOS), Mac OS X, Windows XP> Windows 10 i WordPress (CMS).

Zostaw komentarz

Ta strona używa Akismet do redukcji spamu. Dowiedz się, jak przetwarzane są dane komentarza.